What about Missing Segments?

Yesterday I did a ride I have done often, well at least part of it. I actually added a few new routes and made a 40km loop. On this loop are 3 existing climb 'segments' that Strava has recorded on other previous rides. Yesterday's ride http://app.strava.com/rides/4819269 is missing all 3 segments. I looked at the Map and it has recorded the course accurately but no segments. There was weather and when I reached the top of the climbs the clouds came in and I descended in the rain. I assumed there were no issues with rain as I have done many rides or been caught out in storms before and Strava has always recorded/received my GPS from iPhone. Maybe I have answered my own question, weather was to blame but I'm interested in other's experience with this. Thanks K P Thailand.

Have more questions? Submit a request

Comments

  • Avatar
    Derek Brooks

    i too have a ride i do regularly, and my created segment has had a lot of problems, showing up wrong or not showing up at all.  I had to recreate it and now it doesn't show anyone else has ridden it even though it did previously.  My other rides seem to work fine.  Frustrating.  

  • Avatar
    K P

    Hi Derek,  I can't re create a few of the segments as I didn't create them but I have done this and other rides in the same area and there is a definate drop out of the GPS each time. The iPhone apps says something like 'signal dropped press continue or cancel' or something. When I press continue it picks up where I am. I finish the ride and there is 1 hour of data missing but what happens is the Strava software calculates the missing data and pieces it together. Sometimes it take 30 minutes to calculate but eventually it puts it together, how accurate I don't know but it seems to be good. I will go back to that first ride I wrote about and see if it has put it together.

    Here's the thing. I am on the top of several Mountains, super clear with ample visibility and the only thing I can put it down to is a nearby Military base. My guess is the Thai Army are blocking commercial GPS but there is definately drop outs now, maybe it's a new thing with them I don't know but what sux is I felt like I did the best climb on that sergeant and it wasn't recorded ;-) bummer for me.

  • Avatar
    Adam Caine

    I'm very new to Strava and have been recommended to use it by some of my friends. I was down Cornwall, UK with my dad this week just passed and used it to log two rides but the second one I logged from my iPhone won't load it says "Missing Resource this resource may have been deleted on the strava server". I haven't deleted it. It appears in my 'feed' on my iPhone but it doesn't appear when I log on through my laptop. It's become rather frustrating.

  • Avatar
    Greg Kirk

    Hi KP, me too.  Ride done, went through someone else's segment and has not recorded, which I'm gutted about as I was putting th foot down and I wanted to get KOM!  I looked at my Garmin Connect and it shows me faster by 25secs, but it isn't being recognised by Strava...how do we get this looked at?? Does anyone know?  Thanks

  • Avatar
    Max Power

    More of the same here.  Strava simply didn't recognize the usual public segments in my upload yesterday.  Garmin 800 recorded everything just fine, nothing abnormal about the ride.  Why is there no support response here?

  • Avatar
    Sancho Guapo

    yup, segments not working correctly for me either. Today after my ride (a very popular ride), I added a new segment  to compare to past rides, but it is only showing today's ride. This same scenario was working just fine last week. I must say that segments are the coolest part of Strava, and its no bueno when they don't work. :(

  • Avatar
    Sancho Guapo

    It looks like segments are starting to update now, but it is very slow.

  • Avatar
    Caspar M.

    What happens also is after I shorted a little a segment (too be easier to match) all the previous rides are gone.

    Any idea when the "will come back"?

  • Avatar
    Mark Spies

    yep.. problems here too. I just did a 5km run, set 1k and 5k records - which had to include at least one segment record, but have no achievements come up for the activity...

  • Avatar
    hjan gianluca

    The same for me. 

    I rode this http://app.strava.com/rides/6489846 and I've found this segment  http://app.strava.com/rides/5207074#99276724 but it didn't appear on my ride. Only some climb subsegment were showed.

  • Avatar
    Sancho Guapo

    The segments I created yesterday have now sync'd up with other riders, but they have not sync'd up with my other rides when I go to 'My Results'. Hopefully this is just temporary glitch that can be resolved.

  • Avatar
    Nick Weddall

    Same for me, I bust a lung trying for a KOM... It did have my time as 1 second off the leader in 3rd place. Now there is no mention of it!

    Please sort this out Strava!

  • Avatar
    Dennis A.

    I too, have had this same problem today. I been climbing the same segment for weeks now and getting better. I been using my stopwatch on my cyclocomputer to see my progress and today i actually beat my last time by 25-28 sec and moved to 2nd place for KOM. But today that particular segment was missing from my profile. Pretty bummed out especially coz i hammered up it. Hopefully they'll fix it and record it. Goodluck all!!!

  • Avatar
    Nick Weddall

    Out of interest, are these "missing" segment times recorded using the strava app itself? Mine was, it also gave me 2 identical times on a different segment in the same route...

    I only rode it once!

  • Avatar
    Dennis A.

    @nick- yes I used strava app. The funny thing is I've ridden this segment 10-12 times and it always recorded! That's weird!

  • Avatar
    Tim B

    Not sure if its related or not, but for the last two weeks none of my PR times are being shown or marked as first, second, third etc. I have all my rides set as private, always have and until recently they showed up fine. If i make the ride public, the segments just show a KOM crown, not sure whats going on.

  • Avatar
    Stephen C.

    I'm having nothing but problems with segments.

  • Avatar
    David Armstrong

    Segments not working right for me either. Rode a ride I have done a number of times this morning and it shows one segment as the first time I have ridden it with none of my previous times logged. Using strava with a garmin so it's not the app causing this issue

  • Avatar
    MoZZa .

    Seems to be a common theme. I have 30 entries of 3 or identical rides yet the created segments (4) in each ride only shows up on 25% of the rides. 

  • Avatar
    EJ Ciramella

    Same here - I have an iPhone 4s.

     

    What I see is that the gps shows me off riding in the woods which is totally wrong.

     

    Here's an example:

     

    Correct:

    http://app.strava.com/rides/6973041#130857283

     

    WRONG:

    http://app.strava.com/rides/7364263#z727|829

     

    It's just getting painful to use strava - nothing to tell me I'm approaching a segment, nothing to tell me when I've started, nothing to tell me how far away the end is, nothing to tell me when I've completed the segment, calcuations on moving and average time is really off.

    I've also seen other users with android based phones that show how they rode their bikes through houses and pools and in some cases other impenetrable things.

  • Avatar
    Mike Hoff

    Same here. But, I'm using a garmin edge 500

  • Avatar
    roger kim

    Let's stop with the commercials and ambassadors and Strava kit.

    Let's put my annual membership to use and fix bugs and issues that are echoed through and through.

    For the most part, the Strava user base is very patient, almost saintly.  However, I would not take that as a green light to sack us for premium memberships and under-deliver on the basics of the program.

  • Avatar
    Dylan Penhale

    Happened to me today as well, very frustrating after busting a gut going for a good time. I was using the Garman 705, there were no satellite drop outs.

    Is there a way to add your route to a segment?

  • Avatar
    Mark Spies

    I just ran a PB 10k time... although my Strava dashboard update has no mention of this, and my best 10k time remains unchanged... is anyone from Strava actually addressing these problems?

  • Avatar
    Miguel Creixell

    STRAVA guys, we need a solution to these problem, very frustrating!

  • Avatar
    Enrique H

    I'm currently doing the Mt. Diablo Stage 3 Challenge. I saw that Strava just counted me climbing once today instead of three. (Don't mind that I did it three times, I forgot to turn on my Garmin on the way back the third time, my fault. Why did I ever turn it off? i don't know! It was stupid of me, still annoyed at myself for that one.) Anyways, is there any way to get at least my second climb to count? I'm try to go for the count, since there's no way I can do the Speed time.I know you guys are doing your best to make this app. the best possible, and we appreciate it. PLease Help!

    Thanks Strava!

  • Avatar
    EJ Ciramella

    Seriously people - file a help desk ticket.

    Seriously strava - if you don't like tickets, fix your app to snap to the road or offer a config option!

  • Avatar
    Thomas Haas

    not that it affects my happiness and well being but yes......have the same problem.....awesome big groupride....definetly new KOM'S today.....lots of segments are recorded but not the overall large segment (which the ride was all about)...now i gotta do this again?? ;)....you fix it- i sign up for premium! promise!

  • Avatar
    Thomas Haas

    ...this was on my garmin 500.

  • Avatar
    K. O'Sullivan

    May 15th.  A regular segment near York has just gone missing with all my previous placings/times. I can see other riders results but not mine. The segments part of Strava sets it apart from other GPS log programs. Would be great if it was more reliable. Might have to go back to Garmin connect and I was thinking of upgrading to premium but not until it's totally reliable.

Powered by Zendesk