Knowledge Base/Community Forums/Ask the Strava Community

Answered

What about Missing Segments?

K P
asked this on March 05, 2012 10:36 PM

Yesterday I did a ride I have done often, well at least part of it. I actually added a few new routes and made a 40km loop. On this loop are 3 existing climb 'segments' that Strava has recorded on other previous rides. Yesterday's ride http://app.strava.com/rides/4819269 is missing all 3 segments. I looked at the Map and it has recorded the course accurately but no segments. There was weather and when I reached the top of the climbs the clouds came in and I descended in the rain. I assumed there were no issues with rain as I have done many rides or been caught out in storms before and Strava has always recorded/received my GPS from iPhone. Maybe I have answered my own question, weather was to blame but I'm interested in other's experience with this. Thanks K P Thailand.

 

Comments

User photo
Derek Brooks

i too have a ride i do regularly, and my created segment has had a lot of problems, showing up wrong or not showing up at all.  I had to recreate it and now it doesn't show anyone else has ridden it even though it did previously.  My other rides seem to work fine.  Frustrating.  

March 21, 2012 07:24 PM
User photo
K P
Hi Derek,  I can't re create a few of the segments as I didn't create them but I have done this and other rides in the same area and there is a definate drop out of the GPS each time. The iPhone apps says something like 'signal dropped press continue or cancel' or something. When I press continue it picks up where I am. I finish the ride and there is 1 hour of data missing but what happens is the Strava software calculates the missing data and pieces it together. Sometimes it take 30 minutes to calculate but eventually it puts it together, how accurate I don't know but it seems to be good. I will go back to that first ride I wrote about and see if it has put it together. Here's the thing. I am on the top of several Mountains, super clear with ample visibility and the only thing I can put it down to is a nearby Military base. My guess is the Thai Army are blocking commercial GPS but there is definately drop outs now, maybe it's a new thing with them I don't know but what sux is I felt like I did the best climb on that sergeant and it wasn't recorded ;-) bummer for me.
March 21, 2012 08:20 PM
User photo
Adam Caine

I'm very new to Strava and have been recommended to use it by some of my friends. I was down Cornwall, UK with my dad this week just passed and used it to log two rides but the second one I logged from my iPhone won't load it says "Missing Resource this resource may have been deleted on the strava server". I haven't deleted it. It appears in my 'feed' on my iPhone but it doesn't appear when I log on through my laptop. It's become rather frustrating.

April 06, 2012 02:16 PM
User photo
Greg Kirk

Hi KP, me too.  Ride done, went through someone else's segment and has not recorded, which I'm gutted about as I was putting th foot down and I wanted to get KOM!  I looked at my Garmin Connect and it shows me faster by 25secs, but it isn't being recognised by Strava...how do we get this looked at?? Does anyone know?  Thanks

April 08, 2012 11:30 AM
User photo
Max Power

More of the same here.  Strava simply didn't recognize the usual public segments in my upload yesterday.  Garmin 800 recorded everything just fine, nothing abnormal about the ride.  Why is there no support response here?

April 09, 2012 08:25 AM
User photo
Sancho Guapo

yup, segments not working correctly for me either. Today after my ride (a very popular ride), I added a new segment  to compare to past rides, but it is only showing today's ride. This same scenario was working just fine last week. I must say that segments are the coolest part of Strava, and its no bueno when they don't work. :(

April 09, 2012 07:03 PM
User photo
Sancho Guapo

It looks like segments are starting to update now, but it is very slow.

April 09, 2012 07:26 PM
User photo
Caspar M.

What happens also is after I shorted a little a segment (too be easier to match) all the previous rides are gone.

Any idea when the "will come back"?

April 09, 2012 11:38 PM
User photo
Mark Spies

yep.. problems here too. I just did a 5km run, set 1k and 5k records - which had to include at least one segment record, but have no achievements come up for the activity...

April 10, 2012 01:54 AM
User photo
hjan gianluca

The same for me. 

I rode this http://app.strava.com/rides/6489846 and I've found this segment http://app.strava.com/rides/5207074#99276724 but it didn't appear on my ride. Only some climb subsegment were showed.

April 10, 2012 06:59 AM
User photo
Sancho Guapo

The segments I created yesterday have now sync'd up with other riders, but they have not sync'd up with my other rides when I go to 'My Results'. Hopefully this is just temporary glitch that can be resolved.

April 10, 2012 05:58 PM
User photo
Nick Weddall

Same for me, I bust a lung trying for a KOM... It did have my time as 1 second off the leader in 3rd place. Now there is no mention of it!

Please sort this out Strava!

April 13, 2012 04:14 PM
User photo
Dennis A.

I too, have had this same problem today. I been climbing the same segment for weeks now and getting better. I been using my stopwatch on my cyclocomputer to see my progress and today i actually beat my last time by 25-28 sec and moved to 2nd place for KOM. But today that particular segment was missing from my profile. Pretty bummed out especially coz i hammered up it. Hopefully they'll fix it and record it. Goodluck all!!!

April 14, 2012 11:12 AM
User photo
Nick Weddall

Out of interest, are these "missing" segment times recorded using the strava app itself? Mine was, it also gave me 2 identical times on a different segment in the same route...

I only rode it once!

April 14, 2012 11:21 AM
User photo
Dennis A.
@nick- yes I used strava app. The funny thing is I've ridden this segment 10-12 times and it always recorded! That's weird!
April 14, 2012 08:04 PM
User photo
Tim B
Not sure if its related or not, but for the last two weeks none of my PR times are being shown or marked as first, second, third etc. I have all my rides set as private, always have and until recently they showed up fine. If i make the ride public, the segments just show a KOM crown, not sure whats going on.
April 22, 2012 04:08 PM
User photo
Stephen C.

I'm having nothing but problems with segments.

April 23, 2012 05:01 PM
User photo
David Armstrong

Segments not working right for me either. Rode a ride I have done a number of times this morning and it shows one segment as the first time I have ridden it with none of my previous times logged. Using strava with a garmin so it's not the app causing this issue

April 24, 2012 08:05 AM
User photo
MoZZa .

Seems to be a common theme. I have 30 entries of 3 or identical rides yet the created segments (4) in each ride only shows up on 25% of the rides. 

April 25, 2012 12:22 AM
User photo
EJ Ciramella

Same here - I have an iPhone 4s.

 

What I see is that the gps shows me off riding in the woods which is totally wrong.

 

Here's an example:

 

Correct:

http://app.strava.com/rides/6973041#130857283

 

WRONG:

http://app.strava.com/rides/7364263#z727|829

 

It's just getting painful to use strava - nothing to tell me I'm approaching a segment, nothing to tell me when I've started, nothing to tell me how far away the end is, nothing to tell me when I've completed the segment, calcuations on moving and average time is really off.

I've also seen other users with android based phones that show how they rode their bikes through houses and pools and in some cases other impenetrable things.

April 25, 2012 03:41 PM
User photo
Mike Hoff
Same here. But, I'm using a garmin edge 500
April 25, 2012 08:08 PM
User photo
roger kim

Let's stop with the commercials and ambassadors and Strava kit.

Let's put my annual membership to use and fix bugs and issues that are echoed through and through.

For the most part, the Strava user base is very patient, almost saintly.  However, I would not take that as a green light to sack us for premium memberships and under-deliver on the basics of the program.

April 26, 2012 06:27 AM
User photo
Dylan Penhale

Happened to me today as well, very frustrating after busting a gut going for a good time. I was using the Garman 705, there were no satellite drop outs.

Is there a way to add your route to a segment?

May 02, 2012 12:04 AM
User photo
Mark Spies

I just ran a PB 10k time... although my Strava dashboard update has no mention of this, and my best 10k time remains unchanged... is anyone from Strava actually addressing these problems?

May 02, 2012 02:19 AM
User photo
Miguel Creixell

STRAVA guys, we need a solution to these problem, very frustrating!

May 09, 2012 09:12 AM
User photo
Enrique H

I'm currently doing the Mt. Diablo Stage 3 Challenge. I saw that Strava just counted me climbing once today instead of three. (Don't mind that I did it three times, I forgot to turn on my Garmin on the way back the third time, my fault. Why did I ever turn it off? i don't know! It was stupid of me, still annoyed at myself for that one.) Anyways, is there any way to get at least my second climb to count? I'm try to go for the count, since there's no way I can do the Speed time.I know you guys are doing your best to make this app. the best possible, and we appreciate it. PLease Help!

Thanks Strava!

May 09, 2012 06:04 PM
User photo
EJ Ciramella
Seriously people - file a help desk ticket. Seriously strava - if you don't like tickets, fix your app to snap to the road or offer a config option!
May 09, 2012 08:55 PM
User photo
Thomas Haas

not that it affects my happiness and well being but yes......have the same problem.....awesome big groupride....definetly new KOM'S today.....lots of segments are recorded but not the overall large segment (which the ride was all about)...now i gotta do this again?? ;)....you fix it- i sign up for premium! promise!

May 10, 2012 10:30 PM
User photo
Thomas Haas

...this was on my garmin 500.

May 10, 2012 10:31 PM
User photo
K. O'Sullivan

May 15th.  A regular segment near York has just gone missing with all my previous placings/times. I can see other riders results but not mine. The segments part of Strava sets it apart from other GPS log programs. Would be great if it was more reliable. Might have to go back to Garmin connect and I was thinking of upgrading to premium but not until it's totally reliable.

May 15, 2012 07:24 AM
User photo
Mark Davies

Last 2 rides have only recorded the first half of the ride(up to about 25K) and nothing after that???????????

Only just hidden my post code to 500M, could that be srewing it up?????????

May 18, 2012 11:36 PM
User photo
paul goffey

Starva, have lost all my PR's on my regular rides as they are no longer showing the segments within each ride. Why? As Mark above I have hidden my postcode, does this affect it?

May 21, 2012 02:38 PM
User photo
Tim B
Could be Paul, i had a few segments that I created myself, basically starting in the street in front of my house. I had some issues with PR's not showing as I have my rides set to Private (apparently this is to be fixed on the 22nd of May) but while messing around I set all my rides to Public, then set up a 200m privacy zone around my house. All of a sudden all my personal segments disappeared as well. I spoke to Travis about it, Strava does not take anything into account inside the pricacy zone, in fact it has truncated all my rides by that distance even after I turned off Privacy zone and the only way I can get them back is to delete all of my rides and then upload them again. Another issue I had was that I was getting some GPS drift at the beginning of the ride, even though I sat and waited for the Garmin to be happy with the satellites. A segment will only be calculated if you ride THROUGH the start point, not if you pick it up on the way. So all I ended up doing is shifting the start point of my segments a few hundred meters down the road outside of my Privacy zone and somewhere I ride through on those created segments. Not ideal, but seems to be about the size of it for me at least.
May 21, 2012 03:19 PM
User photo
Geoffrey M.

As well as having a segment missing completely, ive noticed the timings to be a bit out compared to SportTracks measurment of the exact same stretch, today a 0.4 mile long segment was 1m 08s and on SportTracks it was 59 secs, a big difference over such a short distance, whats the deal with that?

May 24, 2012 09:51 AM
User photo
Peter MICHAEL

Same problems for me. A couple of the segments I have been "working"on, have dissappeared, which really aggravated me when I got back from a ride last week, when I thought my gut busting effort may have been good enough for a top 3 spot and found that the segment was no longer there.

 

May 28, 2012 05:12 AM
User photo
Nick Weddall

It's quite frustrating now, I put in a very good effort (IMO) up a notoriously steep hill climb at the weekend. But when I get back home to compare myself to others on that segment - Strava hasn't even added my time to the segment! Despite riding through it... So I created another one in parallel to the established segment to see if it recognised that it was identical to an existing and established segment.

It didn't.

Please, please, please read these complaints Strava... I, along with many others would gladly pay for the premium version if these errors were sorted out.

May 28, 2012 05:38 AM
User photo
Mike Hoff
Fwiw, I've noticed that strava, garmin connect and ascent (Mac software that predates strava) all report the same weird gps tracking since I started having problems with segments. Same with a couple buddies of mine, too. So, I'm not so sure it's Strava, alone, that is the problem. Seems like what garmin calls "gps drift" may be to blame. But for so many to have the same issue, on what I guess are multiple devices (I use an edge 500) - who knows. Maybe a satellite problem? I know that it's fairly recent that I started seeing less great tracking over the maps. But, it's consistent across multiple services/platforms. Maybe we can all provide strava with some info about our devices and check recorded activities across a few platforms to help solve the problem.
May 28, 2012 05:48 AM
User photo
Tim B
Interesting observation, solar flare perhaps?
May 28, 2012 03:41 PM
User photo
Clive Smart

I think the GPS drift is the problem, not necessarily a Strava issue. 

I missed two segments this morning and ended up here looking for a reason why.  Segments is the only reaon i used Strava over Endomondo.

When i looked at my trace the two 'gates' for the segments are roundabout exits (rotary) and the GPS off the road & looks like i have cut the corner, not a significant ammount but i guess enough not to trigger the start.  I'm using endomondo to record my trace and i dont think i can fiddle with the resolution of the time between saves in my trace.

It would be interesting to see if this matches anyone elses problem.

May 29, 2012 12:53 AM
User photo
Chris Morrish

Similar problems for me this morning: hammered up High Holborn in Central London to try and improve my time on the HH/CL segment, got to work and found Strava had not registered me on the segment at all. A look at the route shows me to have allegedly been zigzagging across High Holborn all the way up, as if I was popping into every Mickey Ds and pub along the way (I didn't, honest!). I wouldn't mind but this is slap bang in the middle of the capital city – GPS signal must be as good as it's going to get there. Any solutions Strava?

May 29, 2012 02:19 AM
User photo
Max Power

I had a lost ride with similar issues I complained about here earlier.  I am a premium member and submitted a support ticket.  I was helped immediately and got about half or more of the missing segments patched back into that ride by my support person.  I think most of these issues are entirely derived from GPS drift, and while Strava can fix some of it, its just going to happen here and there.  I use a Garmin 800, so I don't think the hardware could be much better.  I suspect a smart phone might drift a bit more.  While I'm not that ridiculously fast, this is a foggy enough tracking system that I would consider myself to essentially have "won" a segment if I'm in the top 5%, just because of the margin of error.  My garmin is rigged to tell me it's spot accuracy along with the other litany of data it can display and is frequently giving me numbers around 100ft.  This is easily the difference between winning and losing a short segment, or missing it entirely on the map.  Add to that the d-bags who were clearly driving a car through some of these segments (55mph on flat land, I don't effing think so,...) and near the top is good enough for me.

May 29, 2012 03:30 AM
User photo
Max Power

On second thought, I've read about new location tracking chips for smart phones that are significantly more accurate being put in service in the next year or so.  They're edging on wifi and local radio sources, so urban riding could get a lot better for phone users in the future, but again, I think this is a hardware problem, largely out of Strava's control.

May 29, 2012 03:35 AM
User photo
Shane Devine

Happened to me today using my garmin edge. Uploaded my ride, and it has me clearly riding through the segment, but no mention of the segment on strava. weird.

June 03, 2012 08:29 PM
User photo
Alastair C

Same happening to me now. Keeps missing a segment. Nearly killed myself riding it tonight only for it not to register :((

June 04, 2012 01:39 PM
User photo
Joel Payne

All my segment times have dissappeared? Segments are not showing on any of my rides but can be found if searched for but still none of my times showing in the leader board? I've ridden the segments again but no time has been recorded for me?

I have also created a couple of segments of my own and they have totally dissappeared? They are not showing on any of  my rides and can not be found if searched for? In my notifications it shows the segments have been created but when I follow the link to check them out all i get is an error page saying web page can not be found?

Where have all my times and segments gone? Why are segments now not being recorded? Whats going on Strava?

I busted a gut trying to record a good time on a segment today, I got bitten by a dog on the route and didn't stop because I thought I was on for a good time but it's not come up on my route!!!!! Nackard and bleeding and no time to show for it....Gutted!

June 05, 2012 07:17 AM
User photo
D. Pronovost

I don't think it's a satellite problem. I was riding with a group and all the riders got "credit" for segments and I got ZERO. Out of 6 segments on the loop that others got "credit" for, I got none!

 

If it was satellite issue the problem would be more "blanket" and less Isolated (all riders would be robbed)

 

I think it has to be divice drivin but, from what I read here, ALL different kinds of devices seen to be seeing problems.

 

I think it's interesting that the MAIN reason people use, and pay for, Strava (segments) is having trouble and there is no response from the administration.

 

Hopefully it can get hashed out soon. My last 4 rides have been devoid of all segments and I'm getting withdraws!   

June 05, 2012 09:52 PM
User photo
Derek Brooks
And again. Set a PR on a segment today, busted my ass doing it - only for Strava not to record it. Same ride as yesterday, recorded fine. I clearly rode through it, it's obvious on the map. GAH.
June 08, 2012 10:18 AM
User photo
Derek Brooks
And again. Set a PR on a segment today, busted my ass doing it - only for Strava not to record it. Same ride as yesterday, recorded fine. I clearly rode through it, it's obvious on the map. GAH.
June 08, 2012 10:18 AM
User photo
Derek Brooks
And again. Set a PR on a segment today, busted my ass doing it - only for Strava not to record it. Same ride as yesterday, recorded fine. I clearly rode through it, it's obvious on the map. GAH.
June 08, 2012 10:18 AM
User photo
Derek Brooks
And again. Set a PR on a segment today, busted my ass doing it - only for Strava not to record it. Same ride as yesterday, recorded fine. I clearly rode through it, it's obvious on the map. GAH.
June 08, 2012 10:18 AM
User photo
Aaron Zaczek

Try this.

http://strava-tools.raceshape.com/snap/

It will snap your ride to the road. Works a treat.

June 12, 2012 07:54 AM
User photo
Dylan Penhale

"It will snap your ride to the road. Works a treat."

Not if you ride off road, I have just as many issues with segments on off road tracks. 

June 12, 2012 02:21 PM
User photo
Dean Dunn
Just noticed some of the rides I logged in May with the Strava Android app (samsung galaxys2) have disappeared. Got some message about the resource not being available on the server. I'm using aGarmin 800 now and that seems okay, but I'm going to go back and check all my rides. Strava would you care to comment you silence is deafening!
June 27, 2012 11:58 AM
User photo
Matthew Tamasco

I did my same loop again today.  When I check the segments for today only 2 were showing with many missing.  I clicked on the previous ride and they are missing there also?  I can look up the segment on the map and my 7/26 data is shown, but not today's?

August 03, 2012 06:32 PM
User photo
Jon Camden

I created a segments months ago and have ridden it a dozen times. All shown on Starva.  Now it doesn't show up on my previous rides. The segment still exists but I'm not recorded as ever having ridden it!!!! Strange but true.

August 09, 2012 12:17 PM
User photo
Byron Hewett

Same issue.  Routine ride with multiple previous segments recorded and today two segments did record and one did not.  It is annoying because I was hammering (for me anyway) and was probably going to set a new PR.  Bummer!

August 23, 2012 06:45 AM
User photo
Christie Cooley

Having this problem a lot. Any suggestions?  Rode a woods loop three times this weekend, it has multiple segments on it that were missed.

August 27, 2012 04:21 PM
User photo
Nick Weddall

Clearly the team at Strava don't read these complaints, or even care about them, otherwise there would be an official response... I'll put my $59 a year to a better use I think.

August 28, 2012 11:54 AM
User photo
Derek Brooks
No, they do, they just blame the rider / device and never offer a real fix.
August 28, 2012 01:17 PM
User photo
Kevin Grey

Hi, I'm new to strava, quick question - do I have to always record a ride to get my segment times on a ride i,ve already recorded and created segments. I use the  iPhone app.

August 29, 2012 10:32 AM
User photo
Dale Johnston

My problem is that I commute the same route every day, and I have a segment created 50 meters down the road, which goes for 0.4km.  Yet in all the commutes I have done, I have only logged 2 results on it out of the 9 times I have ridden it.  I thought it might be because it is too near the start/Strava hasn't been on long enough/or because I have a privacy zone set up for my house.  But why would it log 2 results?

September 04, 2012 03:07 AM
User photo
Travis Robison
Strava Customer Support
Check Answer

Hello All,

Sorry to hear about your experiences. There are a variety of issues here but it sounds like most of you are frustrated about not matching segments to rides. Please note that these forums are not generally reviewed by Strava support staff because most cases are different in one way or another. And because we likely need more information from you to resolve your specific issue it can become challenging to address them in this type of forum. That's why we strongly encourage any user who is having a problem to submit a support ticket. We are currently completely caught up and will respond within 2 business days (likely even sooner). We'd love to help you. 

In most cases, you don't match a segment because of GPS drift. GPS drift is a common occurrence among GPS devices. Unfortunately we can't prevent GPS drift. Turns out it's hard to consistently track your exact location from satellites that are 12,000 miles in space. So both your route and the segment may have some drift. We do have some built in tolerances to allow for segment matching (because obviously your track will never follow a segment exactly) which allows us to compensate for GPS drift but sometimes your GPS recorded route will still be too far off your actual (ridden or run) route and the segment path. 

If you have a Garmin or other dedicated GPS device, unfortunately we can't really improve your GPS quality, but we definitely recommend checking that you have the most current version of your device software installed. If you use an iPhone or Android device, we may have some tips to help improve your GPS quality however, we're somewhat limited by the phone's GPS services.

If you have a ride that should match a segment, please submit a ticket. In many cases we can manually (or force) match you to the segment(s) you missed. In some cases, unfortunately, we can't. We're always working to improve our ability to automatically and manually match segments and we have enhancements planned in this area which will increase the consistency and accuracy of our segment matching process. 

Hopefully this helps provide some background to the problems mentioned here, but I understand it doesn't fix any problems. Other issues here are likely caused by privacy zones and can likely be fixed (or explained) very easily. Again, we would love to help you have the best experience possible but these forums aren't a good place for us to do that. Please submit a support ticket so that we can accurately diagnose the issue. 

Cheers,

Travis

Strava Support Team

September 13, 2012 03:41 PM
User photo
Carl Frost

I am new to Strava. I started a few months ago. It seemed at first it matched segments in the large metro park where I ride routinely without much issue. Now it seems like it almost never matches... and that includes segments that I was the first to list. I'm really frustrated and have had Strava get a couple to match and a couple they couldn't. I have started just adding the same segment, calling it the virtually the same name.  Carl

September 27, 2012 04:40 PM
User photo
Daniel Levin

This ias what the response was from Strava;

We are working to resolve an issue with the change in iOS6 for the iphone. The new release will time out the gps if there is no activity without warning. This is a function within the operating system so we have to wait for Apple to make some changes. It only effects the location stream that we happen to use and require for segment matching.

As a workaround, if you stop for any period of time, you can click on the app to bring it to the forefront in your iphone and the gps will wake up and continue recording.

I'm sorry this is causing you a problem. We are hard at work for a solution.

Cheers, 
Carl 
Strava Support Team

December 29, 2012 10:07 AM
User photo
Martin Cornish

can someone help all my achievement cups does not show on any rides  which ive done thank u.

May 27, 2013 11:50 AM
User photo
Kevin Craig

Same problem.  Segments on rides that I know I've done many times only show me having done them once or twice.  Really annoying. 

June 23, 2013 08:51 PM
User photo
Bob Flis

This weekend I had a missing segment that always shows up.  When I zoomed in on the map I could see the GPS drifted way off the path for about half the segment.  There is no way any of the algorithms Strava uses could have tracked that.  There is a good explanation Strava gives on GPS drift and how they calculate the segment here: https://strava.zendesk.com/entries/20420427-Why-isn-t-a-segment-showing-up-on-my-activity-

I use a Polar RS800CX and a conversion program to upload the file to Strava.  Until this weekend the GPS has been accurate.  I chalk the error up to an extremely high dew point, light rain, and saturated trees.  This was an out-and-back and the return trip was spot on.

 

 

July 08, 2013 08:48 AM
User photo
Ian Sterling

This is still an issue. I had the following commute home from work yesterday: http://app.strava.com/activities/67416201


The "Moffet Park Sprint" segment (http://app.strava.com/segments/626967) is not listed (nor on my previous 2 rides down that segment), yet I obviously rode that segment. It's not even showing up under hidden segments.

Any help the Strava folks could give would be awesome.

July 16, 2013 09:05 AM
User photo
Travis Robison
Strava Customer Support
Check Answer

Hello All, 

Missing segments is always an issue and impossible to prevent. It's one of the most challenging features to have work correctly 100% of the time. We're continuously looking for ways to improve our algorithms but the problem is usually caused by some GPS drift, which we can't prevent. 

Please create support tickets if you'd like us to try and manually match you to any missing segments and we'll do our best. 

Ian, that segment isn't matched to your activity because of your privacy zone.  You won't match segments where any portion is inside your privacy zone. Part of the reason why I recommend creating support tickets so we can address these issues without having to discuss privacy.

Cheers,

Travis 

Strava Support Team

July 16, 2013 09:41 AM
User photo
Martin Clare

Ta for the explanation, just has the same issue, my Garmin on this and only this section on a 100km ride looks to be about 5 - 10 meters to the side of the road (an open road with no real tree cover), and I was doing so well and maxed out. Would have been up to about 24th from 173rd.

Oh well, I'll have to attack it harder in a few days.

July 16, 2013 12:58 PM
User photo
Kevin Craig
That doesn't explain disappearing segments. I've ridden some segments dozens of times and they show up when I ride them, but this year, for example many instances of that segment from last year or the year before no longer show up. I.e. though I've ridden a segment many times, I only see the most recent 3 or 4 when I click on "My Results." Annoying to say the least.
July 16, 2013 02:14 PM
User photo
Ian Sterling

Travis - that makes sense. I did create a request immediately after posting here.

July 16, 2013 03:29 PM
User photo
Adam Guppy

My Garmin 500 seemed to drop out a few times on this evenings ride [I'm doing the Rapha challenge so used iphone as back up] when I uploaded via the garmin the route is there and I basically went up and down a few hills back and forth etc.] its totally missed a segment on one hill going up but got it on the next , strange? I deleted that ride and uploaded via the iphone which had all the info minus the HR, the elevation was different [slightly increased] I uploade d via garmin connect and the route seemed fine [with a different elevation gain] so I deleted the iphone ride and uploaded the file direct, same as the first one got the whole route but missing a couple of segments, bizarre! Not normally bothered by these things, maybe the hot weather is effecting the garmin satellites? the main thing is the Rapha challenge I want to get every metre of elevation accounted for I've earnt everyone of them :D great challenge strava keep up the good work.

July 18, 2013 02:15 PM
User photo
Bob Flis

I just came across a link to a web site that fixes GPS drift on Strava segments.   http://strava-tools.raceshape.com/snap/ will allow you to copy/paste the url for the bad ride and adjust the route to create a new tcx file.  You drag the A & B pointers to the start and end of the drift, then hover over the A marker until you get a white dot.  You can drag the dot along the correct route to make a blue line.  You'll have to delete the bad ride first before uploading the new file.  I tried this on a previous ride that had GPS drift bad enough to cause me to miss a segment and it fixed it!  I only tried 1 ride so I can't vouch for it working every time for everyone.

July 22, 2013 10:15 AM
User photo
Rhys T

I've had similar experiences to the rest of you with Strava not recording segments which is soooo frustrating when you have bust a lung to beat a PB.  I guess it's down to GPS drift.  It kind of makes segments the best and worst thing about Strava as you never know if all of the effort has been recorded and therefore worthwhile.

@ Bob Fils - thanks for sharing the above, will have a look at it now.

August 10, 2013 04:20 AM
User photo
Mark Bonnes

Just spent a lot of effort chasing a mate down a nice little known DH segment on one of our local rides. I gave him a 15 second headstart. By the end of the (roughly 5 minute) section I was within maybe 5 seconds of him.

He was mapping the ride using the Strava App on his iPhone, me using my Garmin Edge 500. So he was instantly notified of the KOM he just got when he finished the ride. I've just got home after, uploaded my data (expecting to see I'd dethroned him), and lo and behold... Not a sign that I'd even ridden the section, let alone beaten his time! :-/

August 22, 2013 11:27 AM
User photo
Derek A.

https://strava.zendesk.com/entries/20950148-Segment-Matching-Issues I would suggest to submit a request if you haven't done so already. I've had a number of missed segments from my Garmin 800 and Samsung S2 that that have been retrieved after submitting a request also had some that couldn't be retrieved as the recorded gps data was too far out. Make sure your 500 is set on 1sec intervals instead of the default smart recording ..... seen a garmin device recently that had some gps data points over 200m apart on the smart setting. Only had my Garmin 800 for a couple of months, was going to get a 500 until I looked at strava gps tracks from different devices on a recent 4&8hr mtb race I did in a forest with heavy tree cover. The 500s didn't fair that well compared to my phone a Garmin 800 & 510. The Garmin 800 was set on smart recording, half the 500s were on smart recording the rest on 1sec.  I think the 500 is more a road bike device than one to use mtb-ing in the forest. I don't see Garmin advertise it for mountain bikes, only road bikes 

August 22, 2013 02:18 PM
User photo
Elle Anderson
Strava Support

Today, we released a new tool to help Strava users visualize their segment matches and give Strava users more insight and information regarding segment matching. Please take a look, and let us know what you think by posting your feedback on this forum:

https://strava.zendesk.com/entries/27552500-What-do-you-think-of-th...

Thanks! 

February 26, 2014 12:58 PM
User photo
Shane Kratz

I am still having the same issue.  There is a segment that I ride, that comes up when I search 'Segments,' that I have ridden over 100 times.  I am currently the KOM on this segment but since my last ride before winter (November 7), at no time has Strava recognized when I ride the section.  I've ridden about 10 times and when I finish my ride, touch the trophy icon that should show me my current time on that segment, it just says, 'No segments found.'  ???????

March 21, 2014 09:39 AM